Results 1 to 5 of 5

Thread: rct2 won't load. "unable to initialize graphics system"

  1. #1

    rct2 won't load. "unable to initialize graphics system"

    I've had this not work straight from the cd. It was the reason i had to stop playing the games way back in the day. I downloaded it from steam and also own the original game cd. I have switched my compatibility run, changed to administrator settings, ran it from different places. simply cannot get it to work. I am aware microsoft's site says windows isn't compatible, but the old version was. any ideas???? i've been wanting to play this game for months!!!

  2. #2
    what are your System Specs? Windows 7 or 8? GFX, RAM etc

    and your trying to run the game though steam, Correct?

  3. #3
    Have you tried Running it in XPSP3? or set steam launch options for -windowed

  4. #4
    Atari Customer Support ChipmunkAtariCS's Avatar
    Join Date
    Apr 2015

    Please send a support ticket at so that we can better assist you. Access the site and click on “Submit a help request”, select “Technical Support”, fill in your information and click on submit.

    To better assist you with your issue, we would like to request a copy of your DXDiag to review. Please follow the steps below and paste the contents of the file into the ticket you submit.

    To create a DXDiag report, follow these steps:

    1. Click "Start" menu, then click "Run"
    2. In the "Open" box, type: DXDiag (hit enter)
    3. If this is your first time running DXDiag, click "Yes" to launch the DirectX Diagnostic Tool.
    4. Click "Save All Information" to create a DXDiag report.
    5. Choose a name and location for the dump file (for ease of finding it we recommend the desktop) and click "Save".

    Thank you for playing!

  5. #5
    I Recently had to get a New Computer. SAME Specs/Everything but Chip ( a 2.5ghz in place of a 2.2 is the ONLY Difference). Running Windows 7. Bought my Copy From AMAZON. Running a GT520 NVidia. Game Ran Perfectly before the New Computer. Again Only Difference is Speed of Chip. Now I go to Open it and play, I get
    "unable to initialize graphics system".

    I have gone into Properties and Tried Changing Compatibility. I have Tried Changing Screen Resolution. I UNinstalled and REinstalled it and still get the "Unable to Initialize Graphic System".


Similar Threads

  1. Unable to Complete Goal "Carbon Meats Steam Train"
    By RSoxNo1 in forum iOS Support
    Replies: 16
    Last Post: 04-27-2017, 11:45 PM
  2. Bring "Hedge Maze" Back In RollerCoaster Tycoon World
    By AhmadWaliyurR in forum Ideas and Feature Requests - TEMP ARCHIVE
    Replies: 22
    Last Post: 07-19-2015, 08:41 AM
  3. Unable to Complete Goal "Carbon Meats Steam Train"
    By RSoxNo1 in forum Technical Support
    Replies: 0
    Last Post: 03-28-2015, 04:25 PM
  4. Replies: 12
    Last Post: 03-11-2015, 10:01 PM
  5. I would like to request the feature "communication" and "marketing."
    By Menno in forum Ideas and Feature Requests - TEMP ARCHIVE
    Replies: 2
    Last Post: 03-08-2015, 07:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
About us
RollerCoaster Tycoon is back! RCTW is the first new entry to the RollerCoaster Tycoon franchise in a decade, bringing an innovative new track builder, and much more.
Join us