Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: 900+ peeps and huge frame drop

  1. #1

    900+ peeps and huge frame drop

    Anyone else experiencing a huge frame drop when you hit 900 peeps?

    I have dropped down to a pitiful 1fps. but on closed parks I am a happy 30 - 100fps.

  2. #2
    Passive Peep
    Join Date
    May 2016
    Posts
    216
    I have this park which I've been working on, it's up to 1000 Peeps now
    While I'm zoomed out, like in the screenshot, it floats around 20fps. If I zoom in it floats around 30fps. The lowest I see the fps get is when I'm placing something, usually less than 10fps. Rollercoasters are the worst for it, seen it go down to 1fps for a few seconds when placing one of those.
    Attached Images Attached Images

  3. #3
    Yes I have noticed with the more assets in the game the lower the frame rate. The park you saw on my stream suffered from it as I had loads of rocks in the park. I have now decided I will use things like that sparingly so a rethink of the park is needed before next stream.

    Oddly riding a rollercoaster though the frames jump back up to around 90-100fps. Then in park mode it will drop down. I was breathly working on some PxP last night in an empty park before a crash and was getting a healthy 150fps.

    Like all games the more you place the lower the frame rate.

    I have never cared about fps as much as I have with this game. That and I am on a much faster system than before so any impact in a negative way is very much a concern that needs raising.

  4. #4
    Atari Customer Support ChipmunkAtariCS's Avatar
    Join Date
    Apr 2015
    Posts
    461
    Hello and thank you for contacting us.

    We have sent the information provide to our team for them to review and improve on an upcoming update.

    Thank you for playing RollerCoaster Tycoon World.

  5. #5
    Would it be possible for you to give me your PC's specs.
    It would be a big help narrowing down the issue.

    Thanks

  6. #6
    Atari Customer Support ChipmunkAtariCS's Avatar
    Join Date
    Apr 2015
    Posts
    461
    Hello,

    Please make sure you have the latest update installed.

    Thank you for playing!

  7. #7
    Quote Originally Posted by Slade2 View Post
    Would it be possible for you to give me your PC's specs.
    It would be a big help narrowing down the issue.

    Thanks
    AMD A4-6300 APU with Radeon(tm) HD Graphics (2 CPUs), ~3.7GHz
    AMD Radeon (TM) R9 390 Series

  8. #8
    Stall Supporter shirty's Avatar
    Join Date
    Oct 2015
    Posts
    1,523
    Quote Originally Posted by ChipmunkAtariCS View Post
    Hello,

    Please make sure you have the latest update installed.

    Thank you for playing!

    eh? what is this comment even referring to?
    the post before it was over 2 months ago and didnt add anything over the previous chipmunk comment. serveral other month old threads have been given the same sort of comment
    it kinda looks like these messages are either automated responses that have been spammed randomly or if its not automated then how about you pay the slightest bit of attention to what your commenting on and actually provide something of relevance in the comment.
    Atari never fails to amaze, im kinda expecting a reply to this of something like... thanks for your feedback we have passed this information onto the team... blah blah blah

  9. #9
    Quote Originally Posted by shirty View Post
    eh? what is this comment even referring to?
    the post before it was over 2 months ago and didnt add anything over the previous chipmunk comment. serveral other month old threads have been given the same sort of comment
    it kinda looks like these messages are either automated responses that have been spammed randomly or if its not automated then how about you pay the slightest bit of attention to what your commenting on and actually provide something of relevance in the comment.
    Atari never fails to amaze, im kinda expecting a reply to this of something like... thanks for your feedback we have passed this information onto the team... blah blah blah
    I am getting that feeling too. Likewise with the PM of any issues too. Not so much a case of "we'll look into it" or "we are aware of this and are working on it" or "We hope to fix this by...."

    Some of the things people are posting are posting update after update and yet the same response. Where is the personal service and addressing one of the major factors that everyone I know and have spoken to from the forum have all said and that is being forth coming with information.

    It seems the forum and our raising over issues with the game are not only not checked regularly but there is no attempt to put frustrated minds at ease.

  10. #10
    Stall Supporter shirty's Avatar
    Join Date
    Oct 2015
    Posts
    1,523
    Quote Originally Posted by faceless252 View Post
    I am getting that feeling too. Likewise with the PM of any issues too. Not so much a case of "we'll look into it" or "we are aware of this and are working on it" or "We hope to fix this by...."

    Some of the things people are posting are posting update after update and yet the same response. Where is the personal service and addressing one of the major factors that everyone I know and have spoken to from the forum have all said and that is being forth coming with information.

    It seems the forum and our raising over issues with the game are not only not checked regularly but there is no attempt to put frustrated minds at ease.
    i can only assume that they think the last update fixed the issue and they only just got around to checking in (weeks after any update) and let you know that the game performance has been improved so you should check it out to see if its any better.

    thats is all good and well except for the fact that you are pretty much the most active person on this forum and have clearly played the game since the update was pushed and since the game updates automatically (actually cant launch it in an old version) its a completely worthless message.

    if it had said "please let us know if the problem is any better?" then it would be something but it seems like they couldnt care less if it is or not.
    tbh im not sure Atari care in the slightest about this game any more (if they ever did). they certainly dont care about the playerbase evident by the silence across the board with some cut/paste messages once in a blue moon that do nothing to quell/solve the issues.
    i guess that they either dont realise that thier pityful actions are worse than doing nothing or they want to sweep this game under the crapet by treating the remaining players like garbage.

    As with the other recent "Atari" games it seems that they think that soomer or later everyone will stop pestering them to fix the game and add the missing features, then they can finally get some sleep peacefully without being nagged to fix the broken/missing bits of the game and then they can move onto making a mess of the next title in the catalog they bought up when Atari went bankrupt. todays Atari reminds me of the film makers asylum.
    Last edited by shirty; 04-30-2017 at 03:36 PM.

Page 1 of 2 12 LastLast

Similar Threads

  1. Frame Rate Improvements!
    By TheWetDolphin in forum General Discussion
    Replies: 9
    Last Post: 06-06-2016, 05:24 PM
  2. Really Slow Frame Rate
    By danielrayjepson in forum Early Access Sub Forum
    Replies: 5
    Last Post: 04-02-2016, 07:06 PM
  3. Huge FPS Drop When Building Paths
    By Ostinyo in forum Early Access Bug Tracker
    Replies: 0
    Last Post: 03-30-2016, 07:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
RollerCoaster Tycoon is back! RCTW is the first new entry to the RollerCoaster Tycoon franchise in a decade, bringing an innovative new track builder, and much more.
Join us