Results 1 to 5 of 5

Thread: Lag and fps issues since the update

  1. #1

    Lag and fps issues since the update

    Before Wednesday I was enjoying the game immensely and had no issues with performance and pumped 40 how into building my Park. Since the update on Wednesday, I can no longer play the game. The lag is intolerable, my park guests no longer walk, they just float around, my camera movement is so slow, it takes a few minutes to move my screen and trying to build anything is impossible. I have checked to see if it is the graphics setting which is causing my problem, by lowing it it to the lowest setting on everything, and I still have the same problem

    I also have a new issue where the game is taking 5 to 10 minutes to load in after launching the game. During which time, it stops responding two or three times, while loading, this is before the game,e has even loaded. Another problem which I didn't have before the update.

    I can't see this problem being mine alone and as I said, I can no longer play at all, I am loving the early access so far and have had hours of fun playing, I would like to enjoy it again, but unless there is a fix for this, that will hot be possible.

    Please help me.

  2. #2
    Quote Originally Posted by Flash_84 View Post
    I also have a new issue where the game is taking 5 to 10 minutes to load in after launching the game. During which time, it stops responding two or three times, while loading, this is before the game,e has even loaded. Another problem which I didn't have before the update.
    I am having the same problems loading my previous games. I can't load a scenario that actually runs for anything, so it makes them difficult to even try to play. Yesterday, my game completely froze while loading a previous park that had approximately 6 rides, one coaster, and 450 peeps in it. When it finally did load, all I did was save the coaster I built and exit out. The game is just too laggy to play for any length of time right now. Oh, and one of my parks has a single roller coaster in it that I was sandbox building and it's still lagging terribly!

  3. #3
    Nice to know is not just me I suppose. Hopefully there will be a fix for this in the next update. It's really annoying not being able to play anymore

  4. #4
    +1
    Reported this in the bug tracker forums.

  5. #5
    been a issue for me since day one,
    booted up a new park today, decided to just make a small area and work on making it look sort of nice,
    all was going well, nice performance, fps were dipping from 120 to 70/80 but was nice and smooth,
    Then all of a sudden boom, i raised some ground and added some rock/sand textures and the game was unplayable, no idea how such a small change could have such a performance hit,

    defiantly looking forward to some updates for performance and stability i was enjoying myself today up until that point,

    Cheers

Similar Threads

  1. Update issues
    By logi2565 in forum Technical Support
    Replies: 2
    Last Post: 09-17-2019, 12:43 AM
  2. After update Issues
    By marianapdt in forum Early Access Bug Tracker
    Replies: 0
    Last Post: 04-07-2016, 09:36 PM
  3. Lots of issues
    By Ecko0914 in forum Early Access Improvement Tracker
    Replies: 0
    Last Post: 03-31-2016, 03:17 PM
  4. New Update Info + Issues
    By RGamer2009 in forum iOS Support
    Replies: 0
    Last Post: 01-21-2015, 11:36 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
RollerCoaster Tycoon is back! RCTW is the first new entry to the RollerCoaster Tycoon franchise in a decade, bringing an innovative new track builder, and much more.
Join us