View Full Version : Sync progress across devices not working

12-24-2016, 02:34 PM
Hi there,

Im playing between my phone and tablet (both Android devices). I am logged in to the same Play Games account on both devices with sync progress option checked on both devices.
Initially I thought this would be a cloud save (would be a great addition) but it doesnt appear to be so I thought it meant if I complete a scenario on one device it would show this with newly unlocked scenarios on the scenario select screen but this also does not seem to be the case.

01-04-2017, 11:37 PM
So it does work on iOS, at least for the progression data. The actual save files aren't able to be synced though from what I've been able to see which kinda sucks.

For example, if I beat a level on my ipad, that progression will transfer over to my iphone, however the actual game saves themselves don't exist on the iphone, which is definitely kind of lame.

for example, if I start playing a level and save it midway through on my ipad, that save won't show up on my iphone at all. So their system is either working as intended or its kind of broken.

I would personally like to be able to start a game on my ipad and then finish it on my iphone, but that doesn't seem to be how their iCloud progression sync works, it only transfers data on levels that you've completed. Not actual saves between your devices; which again, I think thats kind of lame if that's working as intended.

01-05-2017, 03:18 PM
It doesnt recognise the completed scenarios across my android devices

01-06-2017, 09:01 PM
I'm also seeing the same issue when going from one iPad to another, new iPad. Both running 10.2. In researching on another Atari forum for Transport Tycoon, I found the following from the forum technical sticky.

If you've come across a very tricky issue, we may ask you to upload your save game. If you're on iOS, you can extract your save files with with the PC/Mac application iExplorer: http://www.macroplant.com/iexplorer/ (just get the free trial, that'll work fine). It's fairly self explanatory; install it on your PC/Mac, run the program in demo mode, then connect your iDevice. Your saves will be in Apps > Transport Tycoon > Documents, named XX.sav. 00.sav is the first slot, 01.sav the second, down to the autosave at 49.sav. Getting to the saves on a non-rooted Android device is a bit trickier. If you're using the Google Play distribution of the game, you can use the cloud backup feature to transfer your save to Google Drive, then access it from there. Save files are accepted as forum attachments.


I was able to connect the iPad to a computer, use the trial version to see that the original iPad device had an iCloud folder, with the save games and progression info for rollercoaster tycoon. I copied those files locally to the desktop and then copied them to my iCloud folder on the new iPad manually. It was not apparent if the files needed to be in the root of the iCloud/RCT folder or the iCloud/RCT/Documents folder so I copied them to both. It worked, I'm now playing RCT on the new device with historical progress and save games.

I hope the the above can assist with android devices too. I would believe iexplorer would work much the same. Certainly hope a permanent fix is coming.

01-12-2017, 07:35 PM
I had an issue with cross device save progress
Playing on my Android Samsung Tab A I unlocked and completed
-Factory Capers
-White Water Park
(attached screen shot of the save files showing objectives completed.)

I know I had the Tab A connected and the app open just to make sure all my progress had saved. Closed the App, not just hit the home button actually closed it.

Opened the App on my Android Samsung Tab S (Bigger screen, to continue playing on there) opened the app it did not show me having completed those maps, I closed the app. Re-opened on the Tab A it took away the progress for those two parks, I went to my saved games Those saved games were gone.Like the parks were locked like I had never even unlocked them.
I completed the Trinity islands park, on the Tab A that opened up the the parks (that I lose the progress on) to allow me to play them, I go to save games and the saves are back for those two parks I completed. the progress still has not returned.

I have tried opening the saves since they have been returned, but since they are past the objective completion it does not give me the credit.
I also now have those 2 parks unlocked on the Tab S as well but they do not show completed


01-16-2017, 01:29 PM
Hi, this should now be resolved for Android in version so please update.